
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Electrical Safety Tester

                        190xx

Software User’s Manual





Electrical Safety Tester  
190xx  

Software User’s Manual 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Version 1.1 
June 2013 

 



ii 

Legal Notices 
 
The information in this document is subject to change without notice.  
 
Chroma ATE INC. makes no warranty of any kind with regard to this manual, including, but 
not limited to, the implied warranties of merchantability and fitness for a particular purpose. 
Chroma ATE INC. shall not be held liable for errors contained herein or direct, indirect, 
special, incidental or consequential damages in connection with the furnishing, performance, 
or use of this material. 

 
CHROMA ATE INC.  
66 Hwaya 1st Rd., Kueishan Hwaya Technology Park, Taoyuan County 33383, Taiwan 
 
Copyright Notices. Copyright 2005 - 2013 Chroma ATE INC., all rights reserved. 
Reproduction, adaptation, or translation of this document without prior written permission is 
prohibited, except as allowed under the copyright laws. 
 
 



iii 

Warranty 
 
All Chroma instruments are warranted against defects in material and workmanship for a 
period of one year after date of shipment.  Chroma agrees to repair or replace any assembly 
or component found to be defective, under normal use during this period.  Chroma’s 
obligation under this warranty is limited solely to repairing any such instrument, which in 
Chroma’s sole opinion proves to be defective within the scope of the warranty when returned 
to the factory or to an authorized service center.  Purchaser is responsible for the shipping 
and cost of the service item to Chroma factory or service center.  Shipment should not be 
made without prior authorization by Chroma. 
 
This warranty does not apply to any products repaired or altered by persons not authorized 
by Chroma, or not in accordance with instructions furnished by Chroma.  If the instrument is 
defective as a result of misuse, improper repair, or abnormal conditions or operations, repairs 
will be billed at cost. 
 
Chroma assumes no responsibility for its product being used in a hazardous or dangerous 
manner either alone or in conjunction with other equipment.  High voltage used in some 
instruments may be dangerous if misused.  Special disclaimers apply to these instruments.  
Chroma assumes no liability for secondary charges or consequential damages and in any 
event, Chroma’s liability for breach of warranty under any contract or otherwise, shall not 
exceed the purchase price of the specific instrument shipped and against which a claim is 
made. 
 
Any recommendations made by Chroma for use of its products are based upon tests believed 
to be reliable, but Chroma makes no warranty of the results to be obtained.  This warranty is 
in lieu of all other warranties, expressed or implied, and no representative or person is 
authorized to represent or assume for Chroma any liability in connection with the sale of our 
products other than set forth herein. 
 
 
CHROMA ATE INC. 
66 Hwaya 1st Rd., Kueishan Hwaya Technology Park,  
Taoyuan County 33383, Taiwan 
Tel: 886-3-327-9999 
Fax: 886-3-327-2886 
e-mail: info@chromaate.com 
http://www.chromaate.com 
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Revision History 
 
The following lists the additions, deletions and modifications in this manual at each revision. 
 
Date Version Revised Sections 
Feb. 2005 1.0 Complete this manual. 
   
Jun. 2013 1.1 Add the sections of “Miscellaneous”, “Get Offset Button” and “Get 

CS Button”.  
  Modify the following sections: 

- Descriptions in the section of “Introduction”.  
- Descriptions and Figures in the sections of “Installing Chroma 

EST Software”, “Operation Procedure for Chroma EST 
Software” and “Scan Box Selection”.  

- Descriptions and Figures in the chapter of “Editing Test 
Program”.  

- Descriptions and Figures in the chapters of “Transmission 
Protocol Setting” and “Connection Test (GO/NOGO)”,  
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1. Introduction 

1.1 General Information 
Chroma Electrical Safety Tester is a software for management and statistics report.  Hi Pot 
190xx series (includes 19032P) process test and result analysis under convenient and simple 
human-machine interface by communicating via communication interface.  
 
Notice items: 
 

 The instrument firmware version Chroma EST supported:  
The 19032 is varied by different software version.  

EST Software Version Supported Firmware Version 
1.00 4.00 

5.12 
1.11 5.20 
1.12 5.24 

1.13 ~ 1.16 5.30 
1.17 ~ 2.0 6.00 

2.1.0 6.11 
 

The 19032P is varied by different software version. 
EST Software Version Supported Firmware Version 
Version 2.1.0 or above 1.00~1.90 

2.1.0 3.00 
 

 If users operate Hi Pot desired via this software, please don’t set any setting on the unit 
by manual.  This is for preventing different settings between PC and the unit may cause 
unpredictable error.  

 
 When Chroma EST and the unit are under off-line status, do any modification on the unit 

by manual is need to restart Chroma EST software for avoiding the possibility of the error 
generated.  

 
 

1.2 Requirements 
 Installing the PC with Windows 98 SE/2000/XP operating system.  
 Best resolution 1024x768 lowercase. 
 Communication interface support GPIB and RS232. 
 Microsoft Excel 2000 or above version. 
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2. Installing Chroma EST Software 
Execute Setup.exe in the installation CD to enter the installation procedure as Figure 2-1 
shown. 
 

 
Figure 2-1 Chroma EST Setup 

 
Four items in the main screen: 
 

 Install Chroma EST Software 
Chroma EST main installation program 

 NI VISA and NI IVI Engine 
These two sets of software provide by National Instruments.  According to your  
computer if NI VISA or NI IVI Engine is installed, to decide whether the two sets of  
software kit to be installed.  The installation procedures to suggest you are:  
Installing “NI-VISA” firstly, then “NI-IVI Engine” and “Chroma EST Software” lastly  
for ensure connecting with the instrument correctly.  Moreover, the installation of NI  
VISA and NI IVI Engine are very simple, we don’t explain it further at here.  

※ Chroma can’t provide the software of NI_VISA because of copyright.  However, the NI_VISA 
can be installed by attached CD when purchase GPIB card or these two sets of software can 
be downloaded from NI website by yourself. (http://www.ni.com/visa) 

 Exit: It exits from the installation program.  
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Installing Chroma EST Software 
 
1. First of all, please click ”Install Chroma EST Software” then enter Chroma EST main 

installation program (Figure 2-2). 

 
Figure 2-2 Chroma EST Setup Screen 1 

 
2. Press Next > button to enter license agreement. (Figure 2-3) 

 
Figure 2-3 Chroma EST Setup Screen 2 
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3. Press Yes button, the screen shows customer information about entering user’s name 
and company. (Figure 2-4) 

 
Figure 2-4 Chroma EST Setup Screen 3 

 
4. Press Next > button to select the folder where install file (Figure 2-5).  If you don’t select 

folder, the installation program will setup a default folder for Chroma\ChromaEST system 
software in C: \Program Files automatically.  Thus, all related programs and files are 
installed in this folder.  Press Next > button directly is recommended.   

 
Figure 2-5 Chroma EST Setup Screen 4 
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5. Next, the program starts to install as Figure 2-6 shown. 

 
Figure 2-6 Chroma EST Setup Screen 5 

 
 After Chroma EST software installation is completed, the program will request users to 

install CVI Runtime Engine as Figure 2-7 shown.   

 
Figure 2-7 CVI Engine Setup Screen 6 
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6. After the installation is completed, the program will request the user to reboot to ensure 
this software normal use. (Figure 2-8) 

 
Figure 2-8 Chroma EST Setup Screen 7 
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3. Menu and Toolbar 

3.1 Menu 
 
File Menu 

 

New : Create new .stp file. 
Open…: Open file. (.stp file) 
Save : Save file (Editor: .stp file or Statistics: .bmp file) 
Save As…: Save as new file. (.stp file) 
Print…: Print out (Please refer section 10.1.4) 
Print Preview (Please refer section 10.1.4) 
Exit: Exit from program. 

Edit Menu 

 

Insert: Insert a Step 
Delete: Delete a Step 
Cut: Cut a Step 
Copy: Copy a Step 
Paste: Paste a Step 

Function Menu 

 

Configuration: Switch to Configuration. 
Editor: Switch to Editor (The ticked means the program is in this 
screen) 
GO/NOGO: Switch to GO/NOGO. 
Report: Switch to Report. 
Statistics: Switch to Statistics. 
Management: Switch to Management. 

View Menu 

 

Toolbar: The toolbar is shown or hidden. 
Status Bar: The status bar is shown or hidden.  

 The checked indicates the item is shown, unchecked indicates that is 
hidden.  

Help Menu 

 
About Chroma EST program information.  

Table 3-1 Menu 
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3.2 Toolbar 
The toolbar corresponds to Function menu in function list.  
 

 
 

Configuration : Communication protocol setup 
Editor  : Edit Test Program (called as TP for short, the pressed part in above figure  

indicates the program is in this screen.) 
GO/NOGO : Connection test  
Report  : Create report 
Statistics  : Statistics analysis 
Management : TP Import/Export and User permission control. 
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4. Operating the Program 

4.1 How to Start Chroma EST Software 
If Chroma EST software is already installed in hard disk, a shortcut icon of Chroma EST 
software will be shown on the desktop.  Please double click on this icon, then can start 
Chroma EST software.  Moreover, execute Chroma EST software by clicking [START] → 
[Program File] → [Chroma EST].  
 
After Chroma EST software is executed, Figure 4-1 will be shown as below.  
 

 
Figure 4-1 Login Screen 

 
Please key User ID and correct Password in column of above figure, then press Login to start 
Chroma EST.  If the software is used first time, please key “root” in “User ID” and 
“Password” and then change the password to ensure using safety.  
 
 

4.2 Operation Procedure for Chroma EST Software 
The program enters Open TP Window after login (Figure 4-2).  “Demo” default TP is 
provided for executing the program first time.  If a new TP is desired, click New TP to enter 
New TP dialog box as Figure 4-3.  
 

 
Figure 4-2  
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Figure 4-3 

 
The items of New TP dialog box are described as the following: 
 

 Model Name 
Select the model of Hi Pot single unit.  

 
 Scan Box Count 

The count of Scan Box you need to use.  The number range of inputting is 1~8, the input 
number will effect the below list, the line number is the same as the input number.  Moreover, 
there are a lot of notices for the users.  
 
1. If there don’t insert any Scan Box into the instrument, the number of Scan Box Count 

remains 1, can’t input 0.  The item of No.1 in the lower list should be OFF.  

2. The sequence of selected Scan Box in the lower list should be match to the actual 
connected Scan Box, or unpredictable error will be occurred. 

 
 GR (B) Current Spec. 

Set the instrument used current specification for GR(B) mode.  
 
After all setting are done, press OK key then the program entering Editor window directly, you 
can start to edit Test Program.  
 
The model number and Scan Box in the dialog box are selected.  Thus, the TP is fixed and 
can’t be modified and not for other models connection testing as well.  
 
 

4.3 Scan Box Selection 
Scan Box has two types of Internal and External.  Internal scan box supports 9 models, 
6000-(01 ~ 08) and 6000-11; external scan box supports 3 models, 5000- (01~02) and 
9030-AG.  Settings in Scan Boxes should be noticed as follows.   



Operating the Program 

4-3 

 If the instrument is without internal and external Scan Box, just remain the selection on 
“OFF”.  The software has a GB Floating in default which corresponds to output terminal 
on instrument’s rear panel.  

 
 Set Scan Box internally:  

 
Model: 6000- (01~08), 6000-11 
Key 1 in “Scan Box Count” column, Scan Box table beneath it will show No.1 and then 
select Scan Box model number on No.1.   

 

 
Figure 4-4 

 
 Set Scan Box externally:   

Select the Scan Box model on No.1 directly.  Here, take 5000-02 as an example.     
 

 
Figure 4-5 
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 Set Scan Box internally and externally:  

 
Procedures: 
1. Please key total number of Scan Box in “Scan Box Count” column.   
2. Set internal Scan Box firstly.  
3. Next to set external Scan Box.  
 
Here, take 6000-02, 5000-01 and 5000-02 as example, the figure after setting completed 
is shown as below.  
 

         
Figure 4-6  
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5. Editing Test Program 

5.1 Editor Window 
Follow the previous section, the program enters Editor window after creating a New TP.  The 
program adds a Step (“GB” Mode) for TP users at the beginning as Figure 5-1 shown.  The 
window consists of three parts which will be described as follows. 
 

 
Figure 5-1 Editor Window 

 
 Instrument Information Group: It shows information about TP on instrument.  

Model Name 
It shows the Hi Pot model number which is suitable for TP.  

Scan Box 
The TP used Scan Box, use a comma to separate each Scan Box number.   

 
 Test Steps Group: It consists of three columns - Step, Mode and Ext. Name. 

Step Column 
It indicates how many step of the TP currently i.e. the test step of the TP.  Take the 
figure above as an example, Step1 is for testing GB.  Moreover, each TP contains 
50 steps at most. 

 
Mode Column 

It indicates test items with pull-down menu which includes AC, DC, GB, IR, L/C, 
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Pause and OSC.  The descriptions are as follows.  
 
1. If the selected Scan Box is among 6000-04, 6000-05, 6000-06, 6000-07 and 

6000-08, thus L/C test item will be in the menu.  
2. In the early Firmware version, there is no Pause test item.  Please confirm if the 

instrument supports Pause test item before using it.  
3. Each Mode has its own parameter, thus when users select Step in Test Steps 

Group (click on any column by the mouse), the corresponded parameters will be 
shown on Parameter Group. 

 
Ext. Name Column 

Double click on the area to annotate for this test mode or press Enter to enter edit 
mode for users to key in any character.  

 
 Parameter Group: Test item parameter setting includes three columns - Item, Value and  

Remark. 
Item Column 

It shows parameter name. 

Value Column 
It shows parameter setting.  

Remark Column  
 It shows parameter range.  

 
 

5.2 Add Step 
If users desire to add a new test step, please click on the last Mode column a pull down menu 
button will be popped up.  Click the button and select the desired test item (adding AC Mode) 
to complete the step as Figure 5-2 and the figure after completed as Figure 5-3.  
 

 
Figure 5-2 
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Figure 5-3 

 
From Figure 5-3, users can view the parameter AC Mode to be set are shown on Parameter 
Group.  The parameters in the whole Value column are default given by the program, just 
double click on the column to be changed or press Enter for entering edit mode.  Only 
numeric and decimal point are allowed to key in the column. (“Pause String” in Pause test 
item is excluded.) 
 
As for the definition of each parameter, please refer the user’s manual of various models.  
Here we don’t give detailed explanation furthermore.  A DC test item in Parameter Group is 
“Dwell Time”, TP editor should know if the instrument supports the function.  If the 
instrument doesn’t support the function, please disable it (the program default has this 
function) as Figure 5-4 shown.  Uncheck Check Box in Remark column, the Value column 
will turn into gray that user can’t edit it.  Therefore, the cancellation action is completed as 
Figure 5-5.  
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Figure 5-4 DC Mode Parameter (Dwell Time function default) 

 

 
Figure 5-5 DC Mode Parameter (Disable Dwell Time function) 

 
 

5.3 Scan Box Setting 
See the last item “Channel” in GB Mode Parameter Grid of Figure 5-1.  Click … button in 
Value column, a Scan Box dialog box will be popped up as Figure 5-6.   

 
Figure 5-6 Scan Box Dialog Box (GB Mode) 
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All channels can be set by “6000-02”, “5000-01” and “5000-02” are shown on the dialog box.  
The default value is Off (unused), and the column in gray indicates Channel 6 ~ Channel 8 of 
“6000-02” Scan Box don’t support GB Mode output setting.  If users desire to set a certain 
Channel, the method is selecting the status to be outputted via pull down menu.  
 
The output status will be varied by different Modes.  Assume the current test item is AC 
Mode, Channel output status of Scan Box can be viewed from Figure 5-7.  
 

 
Figure 5-7 Scan Box Dialog Box (AC Mode) 

 
After setting each Channel output status, click OK.  It will return to Parameter Grid for 
viewing all channel statuses which are shown on “Channel” in Value column.  Thus, users 
can see each Channel setting conveniently from Figure 5-8.  
 

 
Figure 5-8 

 
H: High 
L: Low 
O: Off 
X: Don’t support this Mode 

 
One point needs to be explained: If all channels of Scan Box and specified Mode are not to 
be supported, a hint message dialog will be popped up as Figure 5-9 while clicking ….  
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Figure 5-9 

 
 

5.4 Delete Step 
If a Step to be deleted, please highlight the Step.  The highlight method is simple, just left 
click on the Step column to highlight it as Figure 5-10.  
 

     
 
 
 
 

Figure 5-10 Select a Step 
 
After the Step is highlighted, click Edit ->Delete in menu or press Ctrl + D.  The Step 3 (DC 
Mode) will be deleted, the sequential Steps move forward a Step automatically (Figure 5-11).  
 

 
Figure 5-11 

 
 

5.5 Insert Step 
<Step 1> 
To highlight the row desire to insert a Step, refer Figure 5-11.   
 
<Step 2> 
Click Edit->Insert in Menu or press Ctrl + I, the Insert dialog box will be popped up.  

 

Left click here 
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Figure 5-12 

 
<Step 3> 
Choose the Step to be inserted as Figure 5-13, click OK to insert the specified Step.  The 
sequential Steps move backward a Step automatically (Figure 5-13). 

 

 
Figure 5-13 

 
 

5.6 Cut, Copy and Paste Step 
<Step 1> 
To highlight the row desire to cut or copy a Step.  
 
Select (highlight) a Step the user want to cut, copy.  
 
<Step 2> 
If users desire to cut a step, click Edit -> Cut in Menu or press Ctrl + X.  The highlighted step 
will be cut, as “Delete” action the sequential Steps move forward a Step automatically.  If 
users desire to copy a step, click Edit -> Copy in Menu or press Ctrl + C thus the highlighted 
Step will be copied.  

 
<Step 3> 
Paste step is the same as cut and copy.  To highlight a Step firstly, click Edit -> Paste on 
Menu or press Ctrl + V thus paste action is completed.  The sequential Steps move 
backward a Step automatically. 

 
Note The paste action inserts a Step into the highlighted Step instead of overwriting 

the Step.  
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5.7 Save Test Program 
Assume that a TP is already edited currently and accept all default values.  The entire TP 
content is as the figure below.   

 
Figure 5-14 

 
After a TP is edited, execute the TP under GO/NOGO or Report.  Click File -> Save to save 
the TP or click File-> Save as… to open Save as dialog box as Figure 5-15.  

 
Figure 5-15 
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A default file name “_19032” is existed in File Name column for users’ management 
conveniently.  Users also can give the file name instead of default, the example is named as 
“Demo_19032”.  
 
After the files are saved, “GO/NOGO” and “Report“ on toolbar are changed to Enable.  
 
 

5.8 Open Existed TP  
This section describes how to open an existed TP, select Open TP when the program is 
activated and the dialog box is shown.  A TP is opened and another TP to be opened, click 
File -> Open on Menu to enter Open TP dialog box as Figure 5-16.   
 

 
Figure 5-16 Open TP Dialog Box 

 
Each item (a row) has a lot of information in the dialog box.  
 

TP_Name: Name of Test Program 
Release : Release or not (Yes or No) 
Model : The TP specified model 
Scan Box: The TP specified Scan Boxes 

 
What is Release? (Also has description in the sequential section.) 

Release indicates all TP contents can’t be changed.  If a released TP is modified, the 
program will request user to save the modified TP as new file when entering GO/NOGO or 
ending the program.   
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5.9 Miscellaneous  
Click Miscellaneous, other functions will be shown as Figure 5-17.  It is divided into three 
parts, click Save Misc. to save the settings.   
 

 
Figure 5-17 Miscellaneous 

 
 

5.9.1 Preset Function 
Figure 5-17 corresponds to Preset function on stand-alone, some advanced test functions 
can be set at here.  For more function descriptions, please refer stand-alone User’s Manual.  
Before entering Gonogo, the software will process Preset loading firstly and next to download 
test items of TP.  
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5.9.2 Barcode Function 

 
Figure 5-18 Barcode Function 

 
Barcode Group: 
 

 Auto  
It generates serial number automatically and edits the format.  
“Serial Number” The generated serial numbers are based on Prefix, Digit and Start  

No. settings.  
“Prefix”   Prefix word of serial number 
“Digit”   Digit behind prefix word 
“Start No.”  Start serial number 
 

 Barcode  
After this function is activated, click Start(F10) under GO/NOGO to start testing the Scan 
Barcode window will be popped up.  
“Length”    It limits barcode length, the error hint will be occurred when  

over the limit.  
“Scan barcode count” The function provides scanning multiple barcode once.  
“Format(*:omit)” It checks if input Barcode format is correct (* indicates the 

character is omitted).  For example, ”HIPOT0****” is keyed in 
the column that indicates only first six digits ”HIPOT0” will be 
checked and the sequential digits won’t do format check.   
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 None 
Testing only, without any serial number 

 
Report Group: 
 
It generates simple txt report, the tested data file name will be given by scanned Barcode.  If 
the result is Pass thus it will be saved into Pass folder of specified path and Fail folder of 
specified path conversely.  
 

 Auto Output Txt Report 
The function checked indicates the test result will generate txt file each time and place it 
into the specified folder.  
 

 File Path 
It specifies the path for txt file.  

 
 

5.9.3 Option Function 

 
Figure 5-19 Option Function 

 
 Group 

To group the test item, it is for a TP testing multiple DUTs and will be explained detail in 
section 7.  The Group column will be added in Test Steps Window after the function is 
checked and saved.  The numbers to be selected are depended on Count setting.  
 

 
Figure 5-20 Group Column Setting 
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 JUDGEMENT ON PA MODE 
It coordinates with the Group item, the function is changed to settable as Group item is 
checked.  The detail function will be described in section 7.  
 

 FAIL LOCK 
If the function is checked, the test result is Fail and Password column will be shown on 
error message window.  Key in the correct password thus the message window will be 
ended.  
 

 INPUT OFFSET 
The Offset column will be added in Test Steps Window after the function is checked and 
saved.  Users can get Offset value of each test item and save it by clicking Get Offset at 
upper right side of Editor Window.  Open the TP next time and load the parameter to 
single machine, the Offset value will be set into single machine with simultaneous.  It 
will save the action and time of getting Offset at each time new testing.   
 
Note No Offset value under IR mode.  

 

 
Figure 5-21 Offset Column Setting 

 
 

5.10 Get Offset Button 
When  INPUT OFFSET is checked in the previous section, click Get Offset to get Offset 
value of each test item.  Before testing, please ensure the single machine and the entire 
connections are connected.  Therefore, the tested wire loss and the test result at last will be 
accurate.  
 
During Offset test procedure, Editor Screen has real time display effect for users viewing 
execution step currently.  If the Pause mode is encountered during test procedure, the 
software will quit to next step to continue test automatically.   
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Figure 5-22 Offset Testing 

 
 

5.11 Get CS Button 
Click Get CS to get CS value of each OSC test item.  Before testing, please ensure the 
single machine and the entire connections are connected.  Therefore, the tested wire loss 
and the test result at last will be accurate. 
 
During CS test procedure, Editor Screen has real time display effect for users viewing 
execution step currently.  If the Pause mode is encountered during test procedure, the 
software will quit to next step to continue test automatically. 
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6. Transmission Protocol Setting 
Before connecting test (executing GO/NOGO) with the instrument, please set transmission 
protocol in advance.  Select the interface to be used and set a lot of parameters.  Please 
switch the window to Configuration as Figure 6-1 shown. 
 

 
Figure 6-1 Configuration Window 

 
In configuration function, it consists of Interface and Properties.  Interface provides user to 
select using interfaces – RS232C, GPIB and USB, the selection will affect the parameter 
number of Properties setting.  If the GPIB interface is selected, only GPIB Addr control item 
in Properties is enabled.  If the RS-232C is selected, COM Port, Baud Rate and Parity in 
Properties are enabled, whereas the control item of GPIB Addr is disabled.  USB is no need 
to process any parameter setting.  
 
After the Configuration window is set, enter GO/NOGO for connection test at once.  
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7. Connection Test (GO/NOGO) 
Before connecting for the test (execute for GO/NOGO), please be sure that the power of 
instrument is turned off.  The program proceeding the connection for the test before entering 
GO/NOGO, and download each parameters of all steps of TP to the instrument.  There will 
be a schedule list on the status bar under processing connection and download, the mouse 
will show funnel.  After finishing the download and make sure it is correct, the program 
enters GO/NOGO window (Figure 5-9).  
 

 
Figure 7-1 GO/NOGO Window 

 
 

 
Button descriptions are as follows.  
 
Start(F10)  : Start safety test, Offset test or continuous button while encountering Pause  

mode.  
Stop(F2)  : Stop all tests 
Run Offset : Run Get Offset test 
Run CS : Run Get CS test (for OSC mode) 
Report : Open tested report last time in .txt file.  
 
The columns in test result table are described as follows.  
Mode  : Name of test item 
Ext. Name : Annotation of test item 
Output  : Output voltage or current value  

Here shows the 
test reading 
and result.  

Show Total Result
Show Fail Rate 
statistics 

Test Information 
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Reading  : The measured result 
Watt   : The outputted power value of single machine returned to external power  

(for 19032-P + 6000-08).  
PF   : The outputted PF value of single machine returned to external power  

(for 19032-P + 6000-08). 
Result  : Test result Pass or Fail 

 
 

7.1 Report Function 
Click Report at each time a DUT tested, the test result will be displayed.  

 
Figure 7-2  

 
 

7.2 Offset Test 
Its purpose is for calculating wire loss under test mode, the result data will deduct the wire 
loss automatically after safety test is done for getting more accurate test data.  
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Click Start or press “F10” on keypad to enter test program.  If Offset is selected in the 
window, the program will query if process Offset test for test cable and request to connect 
Offset test circuit.   
 

 
Figure 7-3  

 
After Offset test circuit connection is finished (refer User’s Manual) and click OK, the program 
starts to process Offset test.  DANGER icon in Figure 7-4 will be changed from gray to red 
that warns all personnel the instrument outputting high voltage or high current at present.  
Don’t touch the instrument and DUT to avoid mortal danger.  Only Stop can be operated 
under testing, other functions are locked including close program.   

 

 
Figure 7-4 Offset Test Window 

 
The test step includes Pause Mode (such as Step4), while testing the Step the instrument will 
stop output voltage or current and Pause Message will be popped up.  Click OK and 
Start(F10) to continue the test.  
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Figure 7-5  

 
 

7.3 Get CS Test 
Click Get CS to start Get CS test.  The test is for testing OSC mode, its step is the same as 
Offset test.  
 
 

7.4 Safety Test 
Offset test is done or Offset is unchecked, click Start to start safety test.  If the TP Barcode 
setting is Auto or None, the software will start test directly.  If Barcode is selected, Get UUT 
serial number dialog box as Figure 7-6.  The method to input serial number is from Bar Code 
Scanner or by manually.  
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Figure 7-6 UUT S/N Dialog Box 
 
Click OK after serial number is inputted thus enter UUT safety test.  The screen under 
testing is the same as Offset testing, UUT S/N edit column at upper right corner will show 
UUT serial number currently.  During test procedure, users can click Stop or press F2 on 
keypad to stop the test.  
 
A Pause Message will be popped up if encountered Pause Mode.  Pause Mode edited 
messages are shown on the screen for hinting users’ sequential action.  

 
Figure 7-7  

 
After UUT safety test is finished, a lot of information will be shown as Figure 7-8.  It includes 
each Step reading and Result at upper left grid, total test result Pass or Fail word at lower left 
corner, UUT serial No. start, elapse and end time at upper right corner UUT Information 
Group and the TP all tested UUT Fail Rate statistical chart and analysis at lower right corner 
Fail Rate column.  
 
After UUT safety test is finished, Get UUT S/N dialog box will be popped up automatically to 
request users to input next UUT serial number.  
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Figure 7-8  

 
Figure 7-9 is the window test result is Fail, please compare it with Figure 7-8.  
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Figure 7-9  

 
Upper left corner Result Grid in Test Result Fail window generates error when testing Step1, 
“Fail” word in red will be shown on Test Result Column.  The sequential steps are indicated 
by ”????” here due to not tested.  The Fail Rate statistical chart at lower right corner is 
adding red Fail Count histogram, its height is the same as Total Count.   
 
Whatever testing how many UUT, Total Count only has one count.  This is because the TP 
not release yet that test result only remains the last UUT report.  How to release a TP, 
please refer Chapter 8 Test Program and User .  
 
A lot of points need to explain as follows.  

1. After an unreleased TP is run and return to Editor Window for modification.  It will 
cause Step parameter reload and re-execute Offset.  The released TP is without this 
problem, the program will request the modified TP to save as a new TP file and use 
new TP file to do test.   

 
2. Whatever Offset test or safety test, please don’t turn the instrument power off under 

testing.  It avoids the program to happen unpredictable error.  
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7.5 Multiple UUTs Safety Test 

7.5.1 Group Test 
EST software can set Group count to group test item which is used for testing multiple UUTs.  
Refer Figure 7-10 to set Group count in advance.   
 
Click Miscellaneous and “Option” tab,  Group is checked and then input 2 to Count column.  
Click Save Misc., the data will be saved.  
 

 
Figure 7-10 Group Setting 

 
The item to be tested is grouped by Group number and saved the data as Figure 7-11.  
 

 
Figure 7-11 Group Setting in Test Steps 
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Enter GO/NOGO window, the software will load the entire TP into single machine and click 
Start(F10) to start the test.  After the entire TP is tested, the column at the bottom will base 
on Group count to display test result.  

 

 
Figure 7-12 Group Result  

 
There are two LEDs and its definitions are as follows.  
 

 The test step is not tested. 

 The test step result is Fail.  
 
 

7.5.2 Save Judge Data 
The previous section test result is grouped by Group method, the test data don’t be saved 
separately, i.e. there is only an entry of test result can be searched in Report window (Figure 
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7-12, serial number: HIPOT00003).  If the test data is saved by Group, the setting needs to 
do some modifications.  
 

 
Figure 7-13 Judge Setting 

 
Click Miscellaneous and “Option” tab in Editor Window,  JUDGEMENT ON PA MODE is 
checked.  Click Save Misc., the data will be saved. 
 
Insert a Pause mode into two steps and save it.  

 
Figure 7-14 Insert Pause Mode 

 
Enter GO/NOGO test, each test step result in the Group will be shown as testing Pause 
mode.  
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Figure 7-15 Test Result of Group1  

 
Click Start(F10) to continue the test, after the entire TP is tested, the column at the bottom will 
base on Group count to display test result. 
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Figure 7-16 Test Result 

 
Two entries of test result can be searched in Report Window (Figure 7-17, serial number: 
HIPOT00016, HIPOT00017). 

 
Figure 7-17 Test Reports of Two UUTs 
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8. Test Program and User Page 
If a TP to be released, please switch the window to Management.  Two pages in 
Management Window: Test Program and User.  Test Program page can do TP release and 
export, import and delete functions.  User page can do authority control for users. 
 
 

8.1 Test Program  
“Test Program” page is shown as Figure 8-1.  
 

 
Figure 8-1 Test Program Page 
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8.1.1 TP Release Function 
Two columns in Figure 8-1: TP_Name and Release.  It records all TP names currently in TP 
Name column.  It informs users if TP is released in Release column.  If the TP is 
unreleased, a Check Box control item is in the column such as Demo1_9032C, 
Demo2_9032C and released TP is without the check box such as Demo_9032C.   
 
If the TP of Demo1_9032C will be released, please left click on “Check Box” in Release 
column.  A confirmation message will be shown as Figure 8-2.   
 

 
Figure 8-2 

 
Click Yes to complete Release procedure.  Some variations are occurred in the column 
currently.  
1. “Check Box” control item is disappeared.   
2. The color of column turned into purple, it indicates the TP is already released.    
3. Statistics icon on toolbar is changed from Disable to Enable status. (Figure 8-3)  
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Figure 8-3 

 
For other TP Release, just repeat the procedure above.  The TP of “Demo1_9032C” tested 
UUT result in GO/NOGO will be recorded for the sequential Report and Statistics used.   
 
 

8.1.2 TP Export Function 
TP export function can export single or multiple TP to “Export” file at the same time.  Export 
the file to other computer, it will get the same TP and no need to edit repeatedly.  The export 
function won’t export UUT test result (Log Data) simultaneously, i.e. the computer with 
imported TP won’t have Log Data of exported TP computer tested.  The export steps are as 
follows.   
 
<Step 1> Select the TP to be exported by using the mouse, left click for pulling down or press  

Shift, Ctrl as Figure 8-4.  
 

 
Figure 8-4 

 
<Step 2> Click Export key to exit from the dialog box, please input file name to be saved then  
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click Save to complete export action (Figure 8-5). (File extension name is .stx) 
 

 
Figure 8-5 

 
If the TP in activating is a new open one and not save the file yet (UnTitled.stp) thus any 
information about the TP can’t be seen as entering Management Page.  Save the file in 
Editor Page firstly and give it a file name, next to switch it to Management Page for viewing 
the TP related information.  
 
In addition, if the TP is activating and unreleased, the program will show a message to inform 
users that the TP can‘t be exported currently as Figure 8-6 shown.  The reason is that users 
exports the activating TP and saves the revised TP in Editor Page, it will cause the different 
contents between the exported TP and the current TP.  The protection is only for reducing 
the incidence of this condition.  
 

 
Figure 8-6 

 
 

8.1.3 TP Import Function 
The steps for importing a .stx file are as follows.  
 
<Step 1> Click Import key to exit from Open Dialog Box, select the file to be imported (here is 
Test1_Export.stx). (Figure 8-7) 
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Figure 8-7 

 
<Step 2> After clicking Open, Import Dialog Box will be popped up.  The TP information  

can be imported shown on the Import Dialog Box (Figure 8-8).  Select the TP to be  
imported by using the mouse (left click for pulling down or press Shift, Ctrl key), click  
OK to enter next step.  

 

 
Figure 8-8 

 
<Step 3> If the imported TP name is the same as current management name, the program  

will query if rename the imported TP as Figure 8-9 shown.  Click Yes for renaming  
it, the New TP Name Dialog Box will be popped up as Figure 8-10.  Click No for  
not renaming it, the TP all information won’t be imported.  Repeat the step to  
import other the selected TP in Import Dialog Box.  In this example, rename the  
first TP to be imported as “Demo1-1_9032C” and not rename the second one to be  
imported as Figure 8-11 shown.  
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Figure 8-9 

 

 
Figure 8-10 New TP Name Dialog Box 

 

 
Figure 8-11 

 
 

8.1.4 TP Deletion Function 
Delete single or multiple unused TP, the steps are as follows.  
 
<Step 1> Select the TP to be deleted by using the mouse (left click for pulling down or press 
Shift, Ctrl) as Figure 8-12 shown.  
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Figure 8-12 

 
<Step 2> After clicking Delete, it will query if the action to be executed.  Click Yes thus all 
selected TP will be deleted (Figure 8-13).  If the selected TP which is activating, a message 
dialog box will be popped up to inform users the TP can’t be deleted currently (Figure 8-14) 
and the result after deleted is as Figure 8-15 shown.   
 

 
Figure 8-13 

 

 
Figure 8-14 
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Figure 8-15 

 
 

8.2 User Page 
User page as Figure 8-16 includes two columns: User ID and Level Name.  User ID column 
logs current management each User name in the software; and Level Name column displays 
users’ permission.  If Level Name is “Supervisor”, all functions in the program can be 
enabled.  If Level Name is “Operator”, the program only can enter GO/NOGO Window for 
safety test.   

 
Figure 8-16 User Page 
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The functions of Add…, Edit… and Delete are described as below. 
 
Add… : Add a new user. 
Edit… : Edit a user. 
Delete : Delete single or multiple users.  
 
 

8.2.1 Add New User 
Click Add… to add a new user, “Add New User” dialog box will be popped up as Figure 8-17 
shown. 

 
Figure 8-17 Add New User Dialog Box 

 
User ID  : New user name (can’t be blank) 
Password : New user password (can’t be blank) 
Level Name : New user permission (Supervisor or Operator) 
 
Assume that input “TestUser” into User ID column, input “123” for “Password” and select 
“Supervisor” for “Level Name” then click OK, the Input password dialog box will be popped up 
as Figure 8-18 shown.  

 
Figure 8-18 Input Password Dialog Box 

 
After inputting password again, click OK add new user step will be completed.  A new 
created User log will be seen in User Page as Figure 8-19.   
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Figure 8-19 

 
 

8.2.2 Edit User 
Click the User to be modified (click TestUser) next to click Edit…, the program will pop up Edit 
User Dialog Box as Figure 8-20.  
 

 
Figure 8-20 Edit User Dialog Box 

 
Click OK after User ID or Level Name is modified, the program will save the modified data 
and updated User page.  If the password is changed, click OK to show dialog box as Figure 
8-18, confirm the password again to complete the modification.  If the inputted password 
isn’t inconsistent with the previous one, the message dialog box will inform user the password 
error as Figure 8-21 and returns to Edit User Dialog Box.  The setting for each column will 
back to the initial value that is the data as Figure 8-20.  
 

 
Figure 8-21 
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8.2.3 Delete User 
The function is for deleting single or multiple users, click the User to be deleted and click 
Delete thus the program will pop up a message for confirmation as Figure 8-22 shown.  
 
is able to delete one or many users, please select the user you want to delete by the mouse, 
and then press Delete button.  The program will pop up a message for confirmation as 
Figure 8-22 shown.  
 

 
Figure 8-22 

 
Click Yes to complete the deletion as Figure 8-23.  
 

 
Figure 8-23 
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9. Report 
After testing UUT in “GO/NOGO” window, enter “Report” window to create a report.  Click 
Report icon on toolbar, Report Dialog Box will be shown as Figure 9-1.  
 

 
Figure 9-1 Report Dialog Box 

 
In Date Group, it shows from the test date of first UUT to the last one.  Click any pull down 
button  of these two items, a calendar of the current month will be popped up (Figure 9-2).  
Users can choose other dates, click the tested UUT serial number in specified date range 
(the maximum range of these two items is from the test date of first UUT to the last one).   
 

 
Figure 9-2 

 
Users can select if lists UUTs last time retested Log data (default) or UUTs first time tested 
Log data (uncheck Show Lastest Retest Data) in Serial Number Group.  Click Search, all 
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UUT serial numbers under setting condition as Figure 9-3 shown.  
 
If Search is clicked, UUT S/N under new condition to be searched thus clicks Search to 
search again.  
 

 
Figure 9-3 

 
By using the mouse and Ctrl, Shift to choose UUT S/N to be created as report, click OK the 
program will open Microsoft Excel software to fill log data in Excel spreadsheet as Figure 9-4.  
 

 
Figure 9-4 

 
After log data is exported to Excel, a Report icon on toolbar as Figure 9-5 shown.  If the icon 
is clicked, Report Dialog Box will be popped up as Figure 9-1.  Users can select other UUT 
S/N for generating report.  
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Figure 9-5 
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10. Statistics 
Click “Statistics” on the tool bar, Pick UUTs Dialog Box will be popped up as Figure 10-1. 
 

 
Figure 10-1 Pick UUTs Dialog Box 

 
The descriptions for each component are as follows. 
 
Date 

The function is the same as “Date Group” description of Figure 9-1 in the previous 
chapter. 

 
Last UUT 

After the item is selected, the corresponding control item at the right will become 
activating as Figure 10-2 shown.  This function is for users selecting n entry UUTs at 
last test.  Take Figure 10-2 as an example, it selects the last 10 entries UUTs of Log 
data.  

 

 
Figure 10-2 

 
Show Lastest Retest Data 

The function is the same as “Serial Number Group” description of Figure 9-1 in the 
previous chapter. 

 
Pass Only (for Cpk) 

The function is only for Cpk statistics, it checked indicates only count “Pass” UUT 
(default) and unchecked indicates count all UUTs including Pass or Fail.  

 
Accept all default conditions here, click OK to enter Statistics Window as Figure 10-3 shown.  
Four pages in the window: Fail Rate, Fail Item, Cpk and Raw Data.  In Fail Rate, Fail Item 
and Cpk page where divides into two functions.  The left side of window is UUT information 
and the right side of window is parameter setting.  The information in Print Setting Group will 
be shown on statistical figure, the parameters in Parameter Setting Group will affect the 
shape of statistical figure. 
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Figure 10-3 

 
 

10.1 Fail Rate Statistics Chart 
Fail Rate window is as Figure 10-4 shown.  All UUTs’ fail test results in every day are 
regarded as fail rate via viewing fail rate control chart.  The results are gotten by statistics 
analysis.    
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10.1.1 Description 

 
Figure 10-4 Fail Rate Statistics Window 

 
The left window displays the UUT related information, the columns are explained as follows.  
 

No. The serial number by date sequential.  
Select Check box of test result.  The test result of the selected date will 

be included in statistics operation when preview or print statistics 
chart.  

Date It displays test date.  
UUT Pass Count The pass count of UUT test result in a certain date.  
UUT Fail Count The fail count of UUT test result in a certain date.  
UUT Total Count The total count of UUT test result in a certain date.  
 
 Select All  It selects test results of all UUTs.  All check boxes in the window 

will be selected.    

 UnSelect All  It unselects test results of all UUTs.  All check boxes in the 
window will be unselected. 

 Draw Chart  It draws Fail Rate statistics chart. 
 
[Print Setting] 

Title It sets the title for printing. 
Model Name It sets UUT model name.  It is only for displaying, its content can’t 

be modified.   
 
[Parameter Setting] 

1) Sample Size It sets sample size.  
2) Std Err Multiplier It displays standard error of Spec. Max./Min. 
3) Limit Source It sets limit source.  
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 From Selected Data It calculates the control limits by the selected UUTs’ test results. 
 Use Std p0 Use Std p0 as the standard p0 value for control limits center line. 

Std p0 It sets standard p0 value.  
 
 

10.1.2 Display Statistics Chart 
Select the test date result that will be included to calculate from the upper of window then set 
the page of Parameter Setting and Print Setting and click Draw Chart to get Fail Rate 
Statistics Chart as Figure 10-5.  
 

 
Figure 10-5 Fail Rate Statistics Chart 

 
Click Return to back to the window for modifying parameter settings, then click Draw Chart.   
 
 

10.1.3 Save Statistics Chart 
The program supports each statistics chart and save it as 640x480 Bitmap file.  Select File 
-> Save of function list in Figure 10-5 (i.e. it is in Chart Window, the parameter setting window 
cannot save the statistics chart).  A save as dialog box will be popped up as Figure 10-6, 
input the file name desired and click Save to save Bitmap file of the statistics chart under the 
specified directory.  
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Figure 10-6 Save As Dialog Box 

 
 

10.1.4 Print & Print Preview Statistics Chart 
The program supports print and preview functions of all statistics charts.  Select File -> Print 
Preview in function list to print preview statistics chart, the Print Preview Window will be 
popped up as Figure 10-7.  Click Print… on Print Preview Window to enter print procedure, 
click Close to return to Statistics Window.  
 

 
Figure 10-7 Print Preview Window 
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Select File -> Print… in function list to print statistics chart, Print Dialog Box will be popped up 
as Figure 10-8.  After the print item is set, click OK to start printing  
 

 
Figure 10-8 Print Dialog Box 

 
 

10.2 Fail Item Statistics Chart 
Fail Item Window is shown as Figure 10-9.  The fail test results of all steps for UUTs are 
regarded as defect, the results are gotten by statistics operation.  
 
 

10.2.1 Description 
Pass or Fail result of each UUT’s test step are listed in Figure 10-9 (???? indicates the 
previous step is fail so the item doesn’t be tested).  
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Figure 10-9 Fail Item Statistics Window 

 
The left window displays the UUT related information, the columns are explained as follows. 
 

No. The UUT’s number.  
Select Check box of UUT test result.  The selected test result will be 

included in statistics operation when previews or prints statistics chart.
Serial No. The UUT’s serial number.  
  
Other columns display test results of test step are Pass or Fail.  

 

 Select All  It selects test results of all UUTs.  All check boxes in the window will 
be selected.    

 UnSelect All  It unselects test results of all UUTs.  All check boxes in the window 
will be unselected. 

 Draw Chart It draws Fail Rate statistics chart. 
 

[Print Setting] 

Title It sets the title for printing.  Users can input title name arbitrarily.  
Model Name It sets UUT model name.  It is only for displaying, its content can’t be 

modified.   
 
 

10.2.2 Display Statistics Chart 
Select the UUT result that will be included to calculate from the upper of window then set the 
page of Print Setting and click Draw Chart to get Fail Item Statistics Chart as Figure 10-10. 
 



Electrical Safety Tester 190xx Software User’s Manual 

10-8 

 
Figure 10-10 Fail Item Statistics Chart 

 
 

10.2.3 Save Statistics Chart 
Please refer section 10.1.3. 
 
 

10.2.4 Print & Print Preview Statistics Chart 
Please refer section 10.1.4. 
 
 

10.3 Cpk Statistics Chart 
Cpk Window is shown as Figure 10-11. 
 
 

10.3.1 Description 
Step Table displays all test steps of the test program.  Result Table displays all readings of 
Step Table selected test steps.  When users change different test steps in Step Table, all test 
readings of the test step will be updated in Result Table.  
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Figure 10-11 Cpk Statistics Chart 

 
Step Table displays the related information of test steps, the columns are explained as 
follows. 
 

No. The serial number of test step. 
Step The test step name. 
Mode The test item mode.  
Ext. Name The annotation of test step.  

MaxSpec The reference specification high limit of test step (refer the Max. 
reading in Result Table). 

MinSpec The reference specification low limit of test step (refer the Min. reading 
in Result Table). 

 
Result Table displays the test result of a certain test step, the columns are explained as 
follows.   

No. The serial number of test reading. 
Select Check box of test reading.  The selected test reading will be 

included in statistics operation when previews or prints statistics 
chart.  

Serial No The UUT’s serial number. 
Reading The result of test reading.  
Result Test reading is PASS or FAIL.  

 

 Select All  It selects test results of all UUTs.  All check boxes in the window 
will be selected.    

 UnSelect All  It unselects test results of all UUTs.  All check boxes in the window 
will be unselected. 

 Draw Chart  It draws Cpk statistics chart. 
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[Parameter Setting] 

1) Spec. Max It sets spec. max of selected step for calculating Cp, Ca and Cpk 
values. 

2) Spec. Min It sets spec. min of selected step for calculating Cp, Ca and Cpk 
values. 

3) Sigma (Spk) It selects Sigma calculation method. (n: It is for calculating the entire 
mother group; n-1: It is for estimating the entire mother group.) 

4) Number of Bins It sets bin numbers of histogram.     
Use Sturges Rule It gets max and min value from all readings as max and min 

of histogram bins and count bin number based on all 
samples.  The formula is 1+3.3*log (Size of (X)). 

Use Custom Define Bins The max and min of custom define bins and custom define 
bin number.   

Number Custom define bin number 
Bin Max Max bin number 
Bin Min Min bin number 

 
� Display Histogram It selects if display histogram.  

 
CAUTION   If Spec. Max and Spec. Min are not specified, the program will 

retrieve max and min value from all reading of the variable to fill in 
these two columns.  

 If the Sigma of the selected data tends to 0 thus it can’t be calculated 
and drawn.  

 
[Print Setting] 

Title It sets the title for printing.  Users can enter title arbitrarily.  
Model Name Model name for UUT.  The column is for display only, it can’t be 

modified.  
 
 

10.3.2 Display Statistics Chart 
It selects test step of Cpk statistics chart to be drawn and which test readings in Result Table 
to be included for operation.  After the items in two tabs of “Parameter Setting” and “Print 
Setting” are set, click Draw Chart to get Cpk statistics chart as Figure 10-12. 
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Figure 10-12 Cpk Statistics Chart 

 
 

10.3.3 Save Statistics Chart 
Please refer section 10.1.3.  
 
 

10.3.4 Print & Print Preview Statistics Chart 
Please refer section 10.1.4.  
 
 

10.4 Raw Data 
Raw Data window is shown as Figure 10-13. 
 
 

10.4.1 Description 
The readings and results of test steps follow UUT to gather them into the same column and 
exported it to Excel.  Users can analyze the test result further via Excel powerful feature.  
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Figure 10-13 Raw Data Window 

 
Raw Data tab displays the related information of UUT, the columns are explained as follows. 
 

No. The UUT’s number.  
Select Check box of UUT test result.  The selected test result will be 

included in statistics operation when previews or prints statistics chart.
Serial No. The UUT’s serial number.  
  
Other columns display test readings and results of test steps. 
Total Result The total result for this UUT (0: Pass, 1: Fail). 

 

 Select All  It selects test results of all UUTs.  All check boxes in the window will 
be selected.    

 UnSelect All  It unselects test results of all UUTs.  All check boxes in the window 
will be unselected. 

 Export Spec… Export max and min in test steps to Microsoft Excel.  
Export to Excel Export the selected UUTs Log Data to Microsoft Exce.  

 
After the UUTs to be exported are selected (the previous three items are selected in the 
example), click Export to Excel.  “Export Specification” unchecked is as Figure 10-14 shown 
and as Figure 10-15 conversely, their difference is only at the top two rows of the window.  
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Figure 10-14 

 

 
Figure 10-15 
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